Select Download update, navigate to the folder you want to use to store the file, then choose Save.

You must manually unzip and run the setup file from your designated folder in order to update the product.

Version 2.5.28.6 (NOV2021)

Version 2.5.28.5 (AUG2021)

Version 2.5.28.2 (FEB2021)

Version 2.5.28.1 (FEB2021)

NB: This update includes no changes since January but the latest Trainer download link.

NB: While we're working on adding support for the newest GTN trainer version, this release is using the latest databases included with Garmin Trainer 3.0.1.0 and is compatible with the following GTN Trainers: 6.62.4, 6.62.3, 6.50.1 and 6.21.

Version 2.5.27 (SEP2020)

Version 2.5.26 (JUN2020)

This release is compatible with the following GTN Trainers: 6.62.4, 6.62.3, 6.50.1 and 6.21 only.

Version 2.5.25 (MAY2020)

This release is compatible with the following GTN Trainers: 6.62.3, 6.50.1 and 6.21 only.

Version 2.5.24 (APR2020)

Version 2.5.23 (MAR2020)

This release is compatible with the following GTN Trainers: 6.62.3, 6.62.1 and 6.21 only.

Version 2.5.22.2 (FEB2020)

This is a mandatory bug-fix update (bugs introduced in 2.5.22.1)

Version 2.5.22.1 (JAN2020)

This is a mandatory bug-fix update (bugs introduced in 2.5.22)

Version 2.5.22 (JAN2020)

Version 2.5.21.1 (NOV2019)

This is a mandatory update if you've already installed 2.5.21

Version 2.5.21 (NOV2019)

Version 2.5.20.2 (SEP2019)

This is a mandatory update:
The component which is reading and writing the values to the settings files as a bug since v2.5.20.
This may damage the ini files or crash the device.

Version 2.5.20.1 (SEP2019)

Version 2.5.20 (SEP2019)

Breaking Change: Shared route data datarefs have changed and are not backward compatible.
If you're using these, please make sure to contact us to get the latest Professional Additions Guide.

Version 2.5.19.1 (JUL2019)

Version 2.5.19 (JUL2019)

Version 2.5.18 (JUN2019)

Please note: if you were running the simulator as-admin or if you're experiencing a Black Screen problem:
Running the simulator as-admin was preventing the trainer from running as a normal user afterward.
After installing this update, running the simulator as-admin just once more fixes the Windows access rights permanently.

Version 2.5.17 (MAY2019)

Version 2.5.16.1 (APR2019)

Version 2.5.16 (APR2019)

Version 2.5.15 (MAR2019)

Version 2.5.14 (MAR2019)

Version 2.5.13 (FEB2019)

Version 2.5.12 (FEB2019)

NAV->APPR is now an opt-in setting only and requires 'AFMS GPS Selected'.

Version 2.5.11 (JAN2019)

VR controller:
X-Plane 11 SDK doesn't provide controller state to plugins.
This version introduces an experimental hack to support VR controllers on the touchscreen.
Enable the hack in creating any file named: “X-Plane\Output\preferences\RealityXP.GTN.vr_mouse_enable".
NB: file can be empty, only file name matters. Please report to our forums only.

Version 2.5.10 (DEC2018)

Version 2.5.9 (NOV2018)

Version 2.5.8 (NOV2018)

Version 2.5.7 (OCT2018)

About AFMS settings: The GTN supports specific enablement features configured during installation in a real aircraft.
These are regrouped in the configuration panel under Aircraft Flight Manual Supplement (AFMS) and allow changing between VNAV and VCALC modes (GTN Trainer v6.50+), selecting V-Flag Declutter, disabling CDI key etc...

Version 2.5.6 (SEP2018)

Version 2.5.5 (SEP2018)

Version 2.5.4 (SEP2018)

NB: this release focus is primarily GTN Trainer v6.50 compatibility.
It may break compatibility with previous trainers (6.41 and 6.21) and we'll make sure to review all code changes for these in a future update.

Version 2.5.3 (JUN2018)

Version 2.5.2.1 (MAY2018)

Version 2.5.2 (MAY2018)

Version 2.5.1 VR (MAY2018)

Version 2.5 (APR2018)

Version 2.4.16 (APR2018)

Version 2.4.15 (MAR2018)

Version 2.4.14 (FEB2018)

Version 2.4.13 (FEB2018)

Version 2.4.12 (DEC2017)

Version 2.4.11 (DEC2017)

Version 2.4.10 (NOV2017)

Version 2.4.9 (OCT2017)

Version 2.4.8 (OCT2017)

Version 2.4.6 (MAY2017)

Version 2.4 (FEB2017)

Version 2.3 (JAN2017)

Version 2.2.4 (OCT2016)

Version 2.2.3 (OCT2016)

*8.33Hz COM spacing requires XP10.

Version 2.2.2 (OCT2016)

Version 2.2.1 (OCT2016)

Version 2.2.0 (OCT2016)

Version 2.1.0 (SEP2016)

public release.

please see the support website for more support information.